[openal] cannot find -lopenal ... cant find .a file

Chris Robinson chris.kcat at gmail.com
Wed Jun 11 17:10:57 EDT 2014

On 06/11/2014 01:23 PM, Kip Carr wrote:
> I am currently trying to link against the latest openal
> (1:1.14-4ubuntu1) in Ubuntu 14.  I did an apt-get install
> libopenal-dev to get latest.  When I compile I get an error:
> /usr/bin/ld: cannot find -lopenal
> I did a "find . -name "*openal*" in the user folder and this is what
> I get:
> ./share/doc/libopenal-data
> ./share/doc/libopenal-dev
> ./share/doc/libopenal1
> ./lib/x86_64-linux-gnu/libopenal.so
> ./lib/x86_64-linux-gnu/pkgconfig/openal.pc
> ./lib/x86_64-linux-gnu/libopenal.so.1
> ./lib/x86_64-linux-gnu/libopenal.so.1.14.0

Are you building a 32-bit app or 64-bit? What's the actual link command 
it's trying to run?

> This worked under Ubuntu 8 (sorry updating ollllld code) but there
> was an .a file and they were all just located under lib not the new
> x86_64 folder.  Is there a reason the .a file isn't in the latest
> release or any other reason I would be getting this error?  Ive tried
> searching around and there isn't anything on this sort of problem.

The .a file is for static linking, which you generally don't want to do 
with openal. Using -lopenal should find libopenal.so in the compiler's 
lib directories, though.

More information about the openal mailing list