[openal] Building with MinGW...?

Mark Sibly blitzmunter at gmail.com
Thu May 29 21:16:33 EDT 2014


I'm trying to build the latest openal-soft from git with MinGW 4.8.1, but
aren't having much luck.

I tried:

> cd build
> cmake -G "MinGW Makefiles" ..
> mingw32-make all

Which generates a bunch of compiler warnings/errors such as:

D:/openal-soft/include/threads.h:47:52: warning: 'struct timespec' declared
inside parameter list [enabled by default]
 int althrd_sleep(const struct timespec *ts, struct timespec *rem);


D:\openal-soft\common\threads.c:182:28: error: dereferencing pointer to
incomplete type
     if(ts->tv_sec < 0 || ts->tv_sec >= (0x7fffffff / 1000) ||

I tried adding #include <time.h> somewhere but that didn't help.

I was able to cmake/build OpenAL32 using msvc13, but my project is

Sorry for the noob question!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openal.org/pipermail/openal/attachments/20140530/4eceaf00/attachment.html>

More information about the openal mailing list