[openal] OpenAL soft on win32: AL lib: (EE) ALCmmdevPlayback_open: Device init failed: 0x80004005

Lex lex at progger.ru
Sun Oct 12 07:01:00 EDT 2014

hi all,

I am trying to use openal soft 1.16.0 with CAudio 
(https://github.com/R4stl1n/cAudio) on windows 8.1.
I compiled OpenAL soft with visual studio 2012 and tried to run CAudio 
provided samples. Occasionally, but quite often, I get the following 
error message after chosing a playback device:

Available Playback Devices:
0): R
1): R

Choose a device by number: 1

AL lib: (EE) ALCmmdevPlayback_open: Device init failed: 0x80004005
[Error] Failed to Create OpenAL Device.
[Error] OpenAL Error: (null).

[Error] prefixed messages come from CAudio, so that are not of interest. 
I find it strange that error happens not every time but occassionally - 
suggest it can be something thread-related. When I run the same samples 
with creative OpenAL, it works reliably each time.

I also noticed that stock OpenAL outputs list of available devices 
Available Playback Devices:
0): Generic Hardware [DEFAULT]
1): Generic Software

Any help would be very appreciated!


More information about the openal mailing list